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Introduction
Section 508 of the Rehabilitation Act requires Federal agencies to make electronic and information 
technology accessible to users with disabilities, including but not limited to:

● Blindness, color blindness, visual impairment

● Deafness, hearing impairment

● Speech impairment

● Mobility, strength, dexterity or reach impairment

The following sections will detail how to make documents accessible in Microsoft Word, Microsoft 
PowerPoint and Adobe portable document format (PDF). Before making a document in those for-
mats, it is important to understand what makes a document accessible. Accessibility ensures that all 
individuals, regardless of ability, can participate fully. Be mindful of the audience and know that some 
members may not be able to see, hear, move or speak well or at all, and they may not be able to 
understand the information being presented. 
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Alternative Text
Alternative text or alternative tags are an attribute attached to an image describing the nature or 
content of an image. Creating these descriptions is important as it allows users with screen readers 
to understand what the image’s content or function is without having to be able to see it. All images 
must have alt text for a document to be accessible. This includes pictures, illustrations, images of text, 
shapes, charts, SmartArt and embedded objects. Each document type has a different way to create 
alternative text for images and will be described in their individual sections.
Tips for alt text descriptions in all formats:

● Think about what in the image is relevant to the message
● Keep the description concise
● Do not describe every detail unless it is vital to the message being delivered

Best practices for alt text:

● Accurate and equivalent: present the same content or function as the image
● Succinct: use as few words as possible; rarely more than a short sentence or two may be

appropriate
● Do not be redundant: do not provide information that is in the surrounding text

Microsoft Word
Heading usage in Word documents is key to allowing flexibility with a 
screen reader and allowing a user to know what is in the document before 
they begin to read it. This provides users of screen readers and other 
assistive technology (AT) with the structure to navigate by:

● Viewing a list of all the headings on the page
● Choosing top-level heading, next-level heading, etc.
● Reading or jumping by headings

Structure the page with headings in the following 
format:

● Heading 1 – Page title or main content
heading

● Heading 2 – Major section heading
● Heading 3 – Subsection of heading 2
● Section 4 - Subsection of heading 3,

and so on ending with heading 6
● Best practice is to not skip heading

levels

Some users will change the font style to 
alert a change in structure rather than using 
headings. While this practice creates a visual 
structure for some users, there is no structure 
to navigate using this method for AT users. 
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Headings and table of contents

When using Microsoft Word, headings will 
create a consistent table of contents for longer
documents. To properly create this table of 
contents: 

 

● Select the “References” tab on the tool
bar

● Select table of contents – the first
button on the menu

● This will allow readers to easily skip to
sections of the document

Data tables

Data tables are a useful tool when displaying infor-
mation in a Word document. It is important to not 
create tables “by hand” using the tab key because 
they will not be recognized as official tables. To 
create a table, select the “Insert” tab on the tool 
bar and select “Table” on the menu. Be sure to 
identify the first row of a table as a reader row. To 
add alternative (alt) text on a data table:

● Left click on the table
● Select “Table Properties”
● Select the alt text tab on the pop-up

menu
● Fill in the title and description box as

appropriate, considering the tips in this
guide’s alt text section

For alt text on a Mac

● Right-click anywhere on an image
● Choose “edit alt text”
● Enter description

Alt text can be created for pictures, illustrations, 
images of text, shapes, charts, SmartArt and 
embedded objects in a similar fashion by simply 
left-clicking on the item and selecting “alt text” to 
create a description.

Hyperlinks

When using a hyperlink, it is important to 
use descriptive text within the link that does 
not rely on context from the surrounding 
text to let a person know the link’s purpose. 
Keep the amount of text within the link to a 
minimum. Avoid ambiguous link text such 
as “click here”, as this does not provide any 
information about where the link will lead 
the user. To turn the entire link into a more 
user-friendly link name, follow the steps 
below:

● Left click the hyperlink
● Select “Edit Hyperlink” in the pop-up

menu
● Type the desired text into the “Text

to Display” bar located at the top of
the pop-up menu

● Click “OK” and the new text will
display in the same format as the
previous hyperlink

Lists and columns

When lists or multiple columns will be 
present in a document, make sure to 
use the features provided by Microsoft. 
Manually creating lists and columns using 
the tab key can provide visual structure but 
does not provide the structure needed for 
AT users to navigate the page. To create 
columns, select the “Columns” button on 
the “Layout” tab of the top ribbon and input 
the number of columns and decide where 
in the document to place them. To create 
lists, select bullet points or numbers using 
the buttons in the “Paragraph” section on 
the “Home” tab of the top ribbon. 
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Accessibility checker

Utilizing the built-in accessibility checker in Microsoft Word is the simplest 
way to determine if the document will be AT friendly:

● Select “File” in the toolbar
● Select “Info” on the pop-up sidebar
● Select “Check for Issues”
● Select “Check Accessibility” in the dropdown menu

The accessibility checker will pop up on the side and display the inspection 
results. The results will display various items, including: 

● Errors: Content that makes a document exceedingly difficult or impossible for people with
disabilities to access

● Warnings: Content that in most-but-not-all cases make the document difficult for people with
disabilities to access

● Tips: Content that people with disabilities can access but could be better organized or
presented

An example of a warning is “repeated blank 
characters”, which means somewhere in the 
document there are repeated spaces that will 
be read on screen-readers as “space, space, 
space, space” for each space present. The 
simple solution for this is to delete all these 
spaces and properly format the sections with 
the tab key or use the enter key to start a 
new line. Similar to blank characters, blank 
rows in a table will show up as a warning and 
can be fixed by adding text to the blank rows 
or deleting the unnecessary rows in the table. 

Another warning is “hard-to-read text 
contrast”, which can be fixed by changing 
the text or background color to a greater 
contrast such as navy-blue text against a 
gold background. “Unclear hyperlink text” 
is another warning that may show up in the 

checker. This should be examined to see if the 
hyperlink itself has enough information to let the 
user know what type of link they are following 
and what type of information they will receive 
on the next page. The final warning that shows 
up in the inspection is “merged or unmerged 
cells”. The checker will say that important cells 
should not be merged or that some cells should 
be merged. It is up to the document creator to 
determine if that makes sense for the data in the 
table. 

Tips from the accessibility checker can include 
checking the reading order to provide more 
clarity, changing duplicate titles that may be 
present, or adding a placeholder when a heading 
level is skipped. Tips are the most optional 
suggestions present in the accessibility checker 
but may allow the document writer to get their 
point across in a more efficient way. 

It may be necessary to convert a Word document into a PDF. To make sure that the document will 
remain accessible, follow these steps:

● Select “File” from the top ribbon
● Select “Export” from the dropdown menu
● Select the “Create PDF/XPS” button
● Select the “Options” button
● Make sure “document structure tags for accessibility” is check marked under the “Include non-

printing information” section on the pop-up menu
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Microsoft PowerPoint
PowerPoint presentations are primarily visual presentations.
When creating a PowerPoint, it is important to be mindful of 
font size, font type and color contrast.

The font size used in the presentation must be large 
enough to be read from a distance and by those with visual 
impairments. 28 pt font may be large enough for some 
audiences but 36 pt or 44 pt are the best sizes to use.

As for font type, the usage of “fancy” cursive or loopy fonts 
may look nice to the eye of the creator but can be very 
unclear to those with any visual impairment. Use the basic 
fonts with clear spacing such as Arial, Calibri, Georgia, 
Tahoma, or Verdana to ensure the best legibility.

Color contrast is very important. High contrast between text 
and background helps those with vision challenges and 
grabs the attention of the audience more efficiently than low 
contrast. Remember that it is okay to maintain the same 
color scheme through the presentation and while creativity 
is good, the audience understanding the information is the 
primary goal. 
Follow these steps to create alt text in PowerPoint:

● Right click on the image
● Select “Format Picture” from the dropdown menu
● Select the “Size and Properties” icon
● Select “Alt text”
● Enter the description of the Image

 
Reading Order

Reading order is another feature 
offered in PowerPoint that must be 
edited to ensure clarity. Items on 
the screen will be read by a screen 
reader in the order you specify. If this 
is incorrect, the screen reader may 
read content before headings and 
create confusion.

Editing reading order for Windows:

● Select the “Home’” tab on the
toolbar

● In “Drawing” tools, select
“Arrange”

● From the dropdown menu,
select “Selection Pane”

● Arrange items in the order
they should be read with the
first item at the bottom and the
last item at the top

Editing reading order for Mac:

● Go to “Home”
● Select “Arrange”
● Select “Reorder Objects”
● Drag in the order items should 

be read
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Adobe PDF
A PDF is meant to keep the format of the original document. They can be edited, but it is much more 
difficult than editing a regular Word document. PDFs are not typically accessible because they can 
be saved as an image, the color contrast, font type or font size are incorrect, or the PDF tags are 
incorrect. 

As previously mentioned, font size, font type and color contrast are very important to be mindful of in 
the creation of any document. The font used in the document must be large enough to be read from 
a distance and for those with visual impairments. A minimum of 12-point font should be used, but it is 
acceptable to use larger font.

As for font type, the usage of “fancy” cursive or loopy fonts may look nice to the eye of the creator but 
can be very unclear to those with any visual impairment. Use the basic fonts with clear spacing such 
as Arial, Calibri, Georgia, Tahoma, or Verdana to ensure the best legibility. 

Color contrast is very important. High contrast between text and background helps those with vision 
challenges and grabs the attention of the audience more effectively than low contrast.

Using the Accessibility Tool in 
Adobe PDF

There are many options on the Adobe 
tool bar for fixing a document. That 
said, not every document will use every 
tool. Using the Acrobat Accessibility Tab 
performs a full check on the document 
and generates an accessibility report. 
There are additional options within the 
accessibility checker that allow the 
report to be attached to the document 
and allows for specific options, such as 
appropriate color contrast, to be selected 
or unselected based on what the user is 
checking for. It is recommended to run 
a full report to make sure the document 
is as accessible as possible. It is also 
an option to check page-by-page for 
longer documents. Terminology on the 
accessibility checker is as follows:

● Passed: this item is accessible
● Skipped by user: rule was not

checked because it was not
selected in the Accessibility
Checker Options dialog box

● Needs Manual Check: the Full
Check feature could not check the
item automatically. Verify the item
manually

● Failed: the item did not pass the
accessibility check

Tags in a PDF

Tags are used with Adobe PDFs to convey alt text. 
Use PDF tags to provide hidden, back-end structure, 
like a heading system in Microsoft. Make sure that alt 
tags are assigned properly and delete any empty tags. 
Follow these steps to create both kinds of tags:

● Select “Accessibility”
● Select “Add Tags to Document”
● Select “Touch-up Properties” to change the tag

type and edit attribute classes and object

Reading order

Reading order is the order that items on the screen are 
read by a screen reader. To ensure that these items are 
read correctly in a PDF:

● Select “Reading Order” under the “Accessibility”
tab on the toolbar

● Click “Show Order Panel”
● Arrange items in the order they should be read
● Items can be tagged and assigned a reading

order from this menu

Set-up assistant

Set-up assistant is an additional tool offered by Adobe 
that can aid in fixing the entire document. While it can 
be helpful, it should not be relied on to completely fix 
the document. Set-up assistant allows Adobe to change 
the color contrast and allows blank pages to be skipped 
by screen readers. 
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Trainings

WVATS conducts trainings for groups on accessible documents of 
all types with step-by-step instructions, examples and opportunities 
to try it out while the team is with you before you make accessible 
documents on your own. 
Contact us by phone at 304-293-4692 or 1-800-841-8436 or by 
email at wvats@hsc.wvu.edu

The Center for Excellence in Disabilities (CED) is designated as the state’s lead agency for assistive technology services. All printed materials are 
available in braille, electronic format and large print. The project described was supported by Grant Number 90AG0011 from the Administration for 
Community Living.WVU is an Affirmative Action/Equal Opportunity Institution.




